Clever Instant Login Issue (Eastern US)

Major incident Clever Login
2021-11-12 08:30 EST · 28 minutes, 50 seconds

Updates

Resolved

Issue was resolved by Clever.

November 12, 2021 · 08:59 AM EST
Issue

Clever is currently experiencing an issue with Instant Logins for Eastern US users. Please refer to Clever’s status page for the latest updates on this issue: https://status.clever.com/

November 12, 2021 · 08:31 AM EST

← Back