Clever Issue

Major incident Clever Login
2021-11-29 09:43 EST · 1 hour, 58 minutes, 9 seconds

Updates

Resolved

Per Clever- monitoring fix

November 29, 2021 · 11:42 AM EST
Monitoring

Per Clever Status page: Monitoring - Our teams have applied a fix to the issue and we are currently monitoring the situation. We will provide more status updates as soon as they are available. Thank you for your continued patience while we work on resolving this issue.

November 29, 2021 · 09:44 AM EST

← Back