Clever- Intermittent login and portal errors
      
Minor incident
      
        Clever Login
    
    
      
2021-12-07 01:41 PM EST
      
      · 2 hours, 29 minutes
    
  Updates
          Investigating
        
        
December  7, 2021 · 01:42 PM EST
        
      
  
PER CLEVER Status page:  
Investigating - Clever logins and the Clever student, teacher, and parent portals are experiencing intermittent errors, specifically for users in the Eastern US, due to an issue with an underlying service provider. We’re working on a mitigation and will share updates.
← Back
            
DreamBox Reading Status