Classlink Login

Minor incident ClassLink Login
2022-01-24 12:17 EDT · 20 minutes, 10 seconds

Updates

Resolved

Issue resolved

January 24, 2022 · 12:37 PM EDT
Issue

Classlink is Investigating slow response times with logins

https://status.classlink.com/

January 24, 2022 · 12:19 PM EDT

← Back